Backend Slowdown

Incident Report for ShiftMatch

Postmortem

Addressing System Performance Issues and Connection Errors

Our engineering team identified and resolved system performance degradation and intermittent connection errors affecting the platform.

Root cause: We traced the issue to two contributing factors: a recurring processing delay causing periodic load spikes, and a separate network/database issue causing MySQL connection failures.

Resolution: We deployed an emergency fix to production addressing the connection timeouts and queue processing behaviour. We've also added safeguards on the database side to prevent connection exhaustion, and we're refining scheduler and connection pool management to improve resilience going forward.

Current status: The fix is live, and we're closely monitoring system performance and connection stability. We'll post an update if anything changes.

Posted Sep 11, 2026 - 10:34 AEST

Resolved

The incident is now fully resolved. A review will follow in the coming days.
Posted Sep 07, 2026 - 17:35 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 07, 2026 - 14:55 AEST

Update

The fix has proven successful, and we are continuing to monitor. The shifts for this week has been prioritised to ensure minimal disruption.
Posted Sep 07, 2026 - 14:53 AEST

Identified

The issue has been identified, and the fix is now being tested.
Posted Sep 07, 2026 - 14:45 AEST

Investigating

We currently have a slowdown in the speed of processing shifts for staff. This is only in the backend.
Posted Sep 07, 2026 - 11:49 AEST
This incident affected: Backend Services.