Sending Message Issue

Incident Report for ShiftMatch

Postmortem

A background issue with AWS SES (email sending) caused messaging and search to slow and, in some cases, stop on Tuesday, the 1st of September. The issue began after 9.30 am (AEST) and was detected at 11:45 am, when the outages became severe enough to trigger a detection notification. The fix was implemented between 12:00 pm and 1:00 pm, and full resolution was confirmed by 2:00 pm.

Impact

  • Messaging: slowed significantly, with some periods of failure.
  • Duration: approximately 11:30 am to 2:00 pm.
  • Customer-facing impact was limited; some reports were received during the incident.
  • Only backend message sending was affected, and there was no front-end impact.

Follow-up actions

  • Add further time-based monitoring for all background notification services to reduce detection time.
Posted Sep 04, 2026 - 13:47 AEST

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 14:49 AEST

Identified

The issue is an AWS email sending issue. It has been isolated from other problems and we hope to have a fix up shortly.
Posted Sep 01, 2026 - 13:19 AEST

Update

We are continuing to investigate this issue.
Posted Sep 01, 2026 - 12:28 AEST

Investigating

We currently have a backend system that is not sending messages. We are looking into it and will report shortly.
Posted Sep 01, 2026 - 12:28 AEST
This incident affected: Backend Services and Communication.